summaryrefslogtreecommitdiff
path: root/yocto/meta-bsp-rvphone/recipes-bsp/esp32spid/esp32spid_0.1.bb
diff options
context:
space:
mode:
authorUros Majstorovic <majstor@majstor.org>2021-08-27 03:06:13 +0200
committerUros Majstorovic <majstor@majstor.org>2021-08-27 03:06:13 +0200
commit76ec318118106cb25d762de83857f6579c13e273 (patch)
treeac1025b9e79a5eae04b6036d56599c0df98dcb08 /yocto/meta-bsp-rvphone/recipes-bsp/esp32spid/esp32spid_0.1.bb
parent6d270f43cfea8e840463c260b43a6afbd24c1149 (diff)
yocto rename
Diffstat (limited to 'yocto/meta-bsp-rvphone/recipes-bsp/esp32spid/esp32spid_0.1.bb')
-rw-r--r--yocto/meta-bsp-rvphone/recipes-bsp/esp32spid/esp32spid_0.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/yocto/meta-bsp-rvphone/recipes-bsp/esp32spid/esp32spid_0.1.bb b/yocto/meta-bsp-rvphone/recipes-bsp/esp32spid/esp32spid_0.1.bb
new file mode 100644
index 0000000..f403c5b
--- /dev/null
+++ b/yocto/meta-bsp-rvphone/recipes-bsp/esp32spid/esp32spid_0.1.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "esp32 spi daemon"
+SECTION = "base"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+PR = "r0"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}:"
+
+SRC_URI = " \
+ file://src/ \
+ file://LICENSE \
+"
+
+S = "${WORKDIR}/src"
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_compile () {
+ cd ${S}
+ ${MAKE}
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/esp32spid ${D}${bindir}/
+}
+
+DEPENDS = "libgpiod"
+RDEPENDS_${PN} = "libgpiod" \ No newline at end of file