summaryrefslogtreecommitdiff
path: root/recipes-bsp/esp32spid/esp32spid_0.1.bb
diff options
context:
space:
mode:
authorUros Majstorovic <majstor@majstor.org>2021-08-27 02:50:19 +0200
committerUros Majstorovic <majstor@majstor.org>2021-08-27 02:50:19 +0200
commit01270b114be7a82a4dbeae7a3d40c83495224842 (patch)
treea1a37b6fbc3a7e09c47695a0ef980500ad258320 /recipes-bsp/esp32spid/esp32spid_0.1.bb
parent52bbf971706df3752d5a41879495740041a4a735 (diff)
parent5c6a2266ffa6780935959af6c96ffc8dd8e2dc1a (diff)
Merge remote-tracking branch 'meta-bsp-rvphone/master'
Diffstat (limited to 'recipes-bsp/esp32spid/esp32spid_0.1.bb')
-rw-r--r--recipes-bsp/esp32spid/esp32spid_0.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-bsp/esp32spid/esp32spid_0.1.bb b/recipes-bsp/esp32spid/esp32spid_0.1.bb
new file mode 100644
index 0000000..f403c5b
--- /dev/null
+++ b/recipes-bsp/esp32spid/esp32spid_0.1.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "esp32 spi daemon"
+SECTION = "base"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+PR = "r0"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}:"
+
+SRC_URI = " \
+ file://src/ \
+ file://LICENSE \
+"
+
+S = "${WORKDIR}/src"
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_compile () {
+ cd ${S}
+ ${MAKE}
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/esp32spid ${D}${bindir}/
+}
+
+DEPENDS = "libgpiod"
+RDEPENDS_${PN} = "libgpiod" \ No newline at end of file